Normando

Cursor lag in HD Pro 2017 on 2019 iMac

Recommended Posts

With Windows 7 no longer supported, I decided to switch teams and buy an iMac for the high resolution display. The iMac specs are appended below. 

 

I Downloaded and installed my HD Pro 2017 and all looked initially good. However, there is an annoying lag in design mode when moving the mouse. It is particularly noticable with crosshairs on, but happens with crosshairs off too.  

 

Example: When dragging out a new exterior wall, the wall lags behind the mouse an inch or so, and catches up in spurts. 

 

As an experiment, I downloaded HD Pro 2020 with the evaluation key and tried it. In HD 2020 the mouse, and the drawing was objects was smooth as silk.

 

Are there any known tweaks to the iMac or HD Pro 21017 to make this work on the newest iMac?

 

Thanks

 

 

**************************************************************************************************************************************************************************************

Hardware Specifications:
  
Computer:
  Model Name:    iMac
  Model Identifier:    iMac19,1
  Processor Name:    6-Core Intel Core i5
  Processor Speed:    3 GHz
  Number of Processors:    1
  Total Number of Cores:    6
  L2 Cache (per Core):    256 KB
  L3 Cache:    9 MB
  Memory:    8 GB
  Boot ROM Version:    1037.80.34.0.0
  SMC Version (system):    2.46f12
  Serial Number (system):    D25ZQ03SJV3N
  Hardware UUID:    55C395C4-2AB8-54E4-9945-1F0B1FDC6A23

Graphics:
  Radeon Pro 570X:
  Chipset Model:    Radeon Pro 570X
  Type:    GPU
  Bus:    PCIe
  PCIe Lane Width:    x16
  VRAM (Total):    4 GB
  Vendor:    AMD (0x1002)
  Device ID:    0x67df
  Revision ID:    0x00c5
  ROM Revision:    113-D0008A-042
  VBIOS Version:    113-D0008A14GL-003
  EFI Driver Version:    01.B1.042
  Metal:    Supported, feature set macOS GPUFamily2 v1
  
Display:
  Display Type:    Built-In Retina LCD
  Resolution:    5120 x 2880 Retina
  Framebuffer Depth:    30-Bit Color (ARGB2101010)
  Main Display:    Yes
  Mirror:    Off
  Online:    Yes
  Automatically Adjust Brightness:    No
  Connection Type:    Internal

Mouse:
Apple Magic Mouse

Share this post


Link to post
Share on other sites

Hi - I had a similar problem on an MacBook Pro. Holding down the CTRL key while scrolling with the mouse helped speed it up. However, I did eventually switch over to a Windows-based laptop and the issue disappeared altogether.

Share this post


Link to post
Share on other sites

Hello and thanks for the feedback!

 

It would be a shame to go back to Windows, or be compelled to update HD to v.2020 just to run it on the iMac. 

 

Well, I'll keep pursuing a solution, and if I find it, I'll post it here.

 

NBC

Share this post


Link to post
Share on other sites

I'm using HDPro2020 and I have an iMac 2012 (512Mb int. graphics) running OS High Sierra - and there has always been a bit of cursor lag; Thats just the Mac I have researched and I just work with it. It happens on other programs I use also. That spinning beachball is very familiar to me running HDPro - but the software HDPro2020 makes up for it. I have recently also read that the system configuration recommendations on the HDPro website/CA page - recommend a 4Gb 'gaming' graphics/video card - not a workstation video card. Are you working on plan files opened in the iCloud - or directly from from your hard-drive - as access to cloud can add to 'the lag' I realised.

Share this post


Link to post
Share on other sites

Robborito:

 

On your advice I turned off the iCloud Drive. That did seem to make a small difference. Then I tried adjusting the resolution to see what happened. By default, it is running at 2560x1440. After I switched it to low resolution 1600x900, it performed almost respectably. Not a perfect solution, but I may grow accustomed to it. 

 

Thanks for the tip!

 

NBC

Share this post


Link to post
Share on other sites

A lot of apparently flashy "add on's' may look appealing but they all require "resources" to support and run. Anything that I do not need running while I work is either uninstalled or off. Your "undo" setting, if set high can eclipse your RAM and slow things down.

 

If all else fails call Tech support and  see if they have any specific tips.

 

DJP

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now