PCWdesignbuild

Issues with Render in 2019

Recommended Posts

Is anyone else having issues with the rendering in 2019.  I can get a good render, but absolutely cannot get shadows.  I can get reflections to work, only with Enhanced Lighting on, but with that on, the entire render is off.  If anyone has the magic key, I'd love to know!  My video card meets system requirements.

WITH ENHANCED LIGHTING OFF.jpg

WITH ENHANCED LIGHTING ON.jpg

Share this post


Link to post
Share on other sites

Be sure that what you currently have missing is not "turned off" in "Edit - Default Settings - Camera Defaults".

 

DJP

Share this post


Link to post
Share on other sites

Turned on in both default settings and in 3D toggles.  I've seriously tried just about every combination and just can't seem to figure it out.  I feel like there's something I'm missing... but I don't know what!

Share this post


Link to post
Share on other sites

Also - in 2019 there doesn't appear to be a final render option?  And does anyone know a better way to get to the 3D camera view option toggle buttons?  It's tedious to have to go into that drop down menu over and over.  Thanks!

 

Share this post


Link to post
Share on other sites

Cameras have changed a good bit in the 2019 versions.

 

You can change settings in a single camera, or in defaults as shown here.

 

ht1.thumb.jpg.5ffd82f2f4db548048db1ab48a4bc863.jpg

Share this post


Link to post
Share on other sites

I see from your image you are using Pro, but ...

 

You can help everyone by adding this info to your signature (see mine for an example) by clicking on your user name at the top right of the page, click Account Settings, then Signature on the left.

 

Doing so makes it always available, and keeps others from having to hunt for it.

 

Also, turn on Signature Display.

 

SIG.thumb.jpg.50834186010aac12d6bf8b4f01afcc88.jpg

 

----

 

Resources for self help:

 

The built in Help System (always a good place to start)

 

 

 

Share this post


Link to post
Share on other sites
13 hours ago, alfrosen6 said:

Yes. I have the same problem.  I have submitted the issue to technical support. 

winter pro 2018.jpg

winter pro 2019.jpg

 

Weird!  I'm glad I'm not alone, though.  Hopefully there's just a setting we're missing - otherwise it's going to be very frustrating trying to get realistic renders to clients!  I also submitted a tech support ticket yesterday but haven't heard back, yet.  

Share this post


Link to post
Share on other sites

If this is the best they can do, I want my money back.  I could not find any information in the help documentation specifically on Pro 2019 features.  It would be interesting to see if we both get the same responses from technical support.

Good luck!

  • Upvote 1

Share this post


Link to post
Share on other sites

I agree.  There seems to be no support or troubleshooting for 2019 yet and when I read through the accompanying documents, some of the menu items weren't even addressed.  I haven't gotten a response yet, but hopefully will, soon!  I owe renderings to clients this week!

Share this post


Link to post
Share on other sites

Keep in mind that the latest version has only been out for a few days. That does not mean that other particular users who helped develop these versions cannot help (I have helped develop all versions of Home Designer and Chief Architect Premier since 1999) are not here to help and also the Tech Support and Software Architects and Engineers at Chief Arachitec Inc are also there to communicate with.

 

I can get usable renders in Home Designer titles as well as Chief Architect Premier presently. It is a matter of finding the right settings, adjusting material and lighting settings, this has not changed since 1999.

 

You are each free to have your own opinions and to make your own decisions as it should be. I currently do not use "Physically Based Rendering" except on a trial and error basis. This rendering technique is brand new with this release and is not as refined now as it will be later. For now, I recommend just using the "Standard" rendering technique which has not been added to or changed; it still works the same way as it did in older versions.

 

DJP

Share this post


Link to post
Share on other sites

Hi David,

 

I appreciate your input - I love the program, but if this issue continues, I'd prefer to go back to my previous version.  The other user and I both have issue tickets in with Tech Support and are awaiting help.  

 

You're able to get renderings in Home Designer Pro 2019 without issue?  The settings have indeed changed quite a bit, seemingly - I'm a long time Home Designer user, with a tech background, but am completely stymied as to how to make this thing work properly.  It's never given me shadows, even when restored to default, or adjusting lighting, sun, or any other option.  If you know the proper adjustments, perhaps you could share so I could try them on my end?

 

Thanks!

Share this post


Link to post
Share on other sites

I was requested to provide screen shots by Anne Smith, the tech assigned to my case.  She also had me provide her with message logs, the plan file.  Right now all I can really say is that there seems to be no Pro 2019 feature specific help documentation.  I too have used Designer Pro through several version upgrades.  All, except this one have been improvements. The enhanced lighting feature seems to a part of the issue.   Also by disabling enhanced lighting, I get a rendering very similar to that of Pro 2018, except there is still no shadowing, nor are there any reflections.  The Pro 2019 renderings are very dark when using the default ambient lighting setting.  I have to turn up ambient light to maximum to get a rendering that is  marginally usable.

 

I am waiting on response from tech support.

  • Upvote 1

Share this post


Link to post
Share on other sites

David,

 

Thank you for your response.  I think i'll continue to use Pro 2018 for a while until Pro 2019 has its kinks worked out. I am confident that Chief Architect's Home Designer is the best software available to the DIYer like myself.

 

Al Rosendale

 

 

Share this post


Link to post
Share on other sites

David - thanks for your candor.  It's very appreciated. 

 

I went back to the Home Designer website and looked at their promotional materials for 2019 - it shows beautiful renderings like we've gotten before in previous versions, so it would seem that someone is able to use the program effectively?  Or this is false advertising?

 

I'm eager to move forward with 2019, but this is really cramping my productivity!

Share this post


Link to post
Share on other sites
19 hours ago, alfrosen6 said:

I was requested to provide screen shots by Anne Smith, the tech assigned to my case.  She also had me provide her with message logs, the plan file.  Right now all I can really say is that there seems to be no Pro 2019 feature specific help documentation.  I too have used Designer Pro through several version upgrades.  All, except this one have been improvements. The enhanced lighting feature seems to a part of the issue.   Also by disabling enhanced lighting, I get a rendering very similar to that of Pro 2018, except there is still no shadowing, nor are there any reflections.  The Pro 2019 renderings are very dark when using the default ambient lighting setting.  I have to turn up ambient light to maximum to get a rendering that is  marginally usable.

 

I am waiting on response from tech support.

This is exactly what I'm experiencing.  I have a tech on my trouble ticket but don't have communication from him, yet.

 

I think the issue is with the enhanced lighting, as well = with it on, everything is dark and unstructured.  With it off, I get a fairly good rendering, but absolutely no shadows or reflections.  Fingers crossed for a fix!

Share this post


Link to post
Share on other sites

This is the response I have gotten from tech support:

 

Thank you for the additional information. I took a look at your plan file in version 2019 but was unable to reproduce any problems that you describe - the lighting and shadows look correct without making any adjustments to the ambient light.

Your Message Log file indicates that your computer has an AMD Radeon HD 7660D graphics card, though, and my thought is that this may be the cause of the problem. This is an older graphics card that is no longer supported by AMD, and although you do have the latest drivers, they are over 2 1/2 years old. AMD does offer a 'beta' driver dated 2/29/2016, so you might consider downloading and installing it:

https://support.amd.com/en-us/download/desktop/legacy?product=legacy3&os=Windows 10 - 64

If this doesn't help, though, I'm afraid that your graphics card isn't going to be able to handle the updated lighting in version 2019.

I hope that this information is helpful.

 

So, this is the response I got from tech support. Before I purchase a new graphics card, I want to see if how many others are having after upgrading to Pro 2019.  David, based on your candid response and what I am getting from tech support, I am very interested to see what happens over the coming weeks.

Share this post


Link to post
Share on other sites

The video card on my laptop is just a year old, the video card on my desktop is about five years old but both are still supported actively by NVIDIA. There have been some complaints relative to Ray Tracing in X10 (HD Pro's Big brother to Home Designer Pro 2019) but nothing really serious, I have had no trouble gaining professional grade images in Pro 2019 or X10, nor have I heard anything like your complaint at Chief Talk but also as I earlier said, the new Home Designer titles have only been on sale for a few days.

 

DJP

Share this post


Link to post
Share on other sites

I got the same response - that my video card, while supported, was running on a driver that might be too old.

 

It's the latest driver for my video card though.  I'm also more than happy to put in a new video card, but I, too, wanted to make sure that doing so would actually fix the problem.  

 

David, you said in a previous post that you and others who worked on the development end were also having issues and complained about the same things we are having issues with.  Are you saying that you can now render with shadows and reflections in Pro 2019?  Could you attach one of your Pro 2019 renderings so I and others can see what quality you're getting?

 

Thanks!

Share this post


Link to post
Share on other sites

Same issue here. I have a Core-I7 PC w/ 8Gb ram, and a Radeon HD5700 series 2Gb Radeon video card as well. No shadows can be made to appear in the room camera views. In Perspective Full Overview the camera view is entirely white, except for landscape plants, when "Preferences-> Render->use enhanced lighting" option is checked.

 

Updated AMD driver to the latest version. Video card is orphaned.

 

That said, I don't recall having these issues with HD Pro 2016.

 

My present video card exceeds the minimum requirement as well. I routinely use this same PC to design electronic circuit boards in a 2D and 3D mode, with no issues. The E-CAD software used costs about $12K-15K per seat.

 

Take a look at CA's video card suggestion recommendations. What is suggested is not an inexpensive upgrade. One shouldn't have to start changing out pcs of expensive PC hardware just to make the $500 CA software work correctly.

 

Judging from DJP and other's comments, perhaps something is amiss at CA.  Of course, I can use HD Pro as is, but to get the most usefulness out of the software, I would have to start replacing PC components, starting with the video card, etc. Where does it stop? Jeez.

  • Upvote 1

Share this post


Link to post
Share on other sites

Yes - I'd wager that most of us who utilize this program on a daily basis are running it on some pretty serious machines.  I upgraded from Pro 2017 to Pro 2019 - I never had any issues in 2017, or any of the versions of the software I've used for almost a decade.

 

I'm not certain that this is a video card issue, actually, because it would seem that certain things could be made to work by "turning off" options which have a heavy drag on our systems.  So far, even with every possible option turned off, I still cannot cast a shadow or get anything other than a fairly flat looking rendering.

Share this post


Link to post
Share on other sites

I recently noticed an abnormality with the display of some textures in the 2018 versions. 

I think that most users expect a decent 3d render.  What's going on?

 

 

Share this post


Link to post
Share on other sites

The following was posted on the Chief Architect Website:

PBRT & Ray Trace Fixes:
3.19 3D Rendering
• Fixed an issue where the artistic effects of Line Drawing were lessened when Edge 
Smoothing on Idle was in use.
• Fixed a problem in the Physically Based Rendering Techniq ue that caused fireplaces to be lit incorrectly on the exterior. 
• Fixed some cases where Matte material types would appear to have reflections in the Physically Based Rendering Technique.
• Fixed an issue where materials with a high Roughness value would appear slightly 
reflective in the Physically Based Rendering Technique.
• Improved performance of the generation of new 3D views, including previews in the 
Library Browser and in dialogs. 
• Fixed an issue where fence newel posts could be lit incor
rectly in the Physically Based 
Rendering Technique.
• Removed the Opaque Glass option from the Physically Based
Rendering Technique.
• Fixed an issue where louvers on bifold doors in legacy pl
ans would sometimes be lit 
incorrectly in the Physically Based Rendering Technique.
• Fixed a problem that someti
mes caused reflective objects 
to appear black after being 
edited in the Physically Based Rendering Technique.
• Fixed some artifacts that could occur in exterior views w
hen a large terrain was pres-
ent and Improve Light Quality was turned in the Physically Base
d Rendering Technique.
• Fixed an issue where setting Hardware Edge Smoothing to “
None” on some Macs 
would cause 3D to be incorrect.
• Fixed a problem that caused rooms separated by Room Divid
ers to sometimes be lit 
incorrectly in the Physically Based Rendering Technique.
• Fixed an issue that caused Mirror Reflections to be too d
ark when Improve Light Qual-
ity was checked in the Physic
ally Based Rendering Technique.
• Fixed a specific case in the Physically Based Rendering T
echnique that caused the view 
would become overly bright and washed out.
• Fixed an issue where clicking Reset to Defaults on the Ph
ysically Based panel of the 
Rendering Technique Options dialog 
could cause the current view
be incorrect.
• Fixed an issue where the Color toggle did not immediately
effect Orthographic views in 
some cases.
• Fixed a specific case where Wall Material Regions were no
t lit correctly in the Physi-
cally Based Rendering Technique.
6
• Fixed a case where the windo
ws in a Bay/Box/Bow Window co
uld be lit incorrectly in 
the Physically Based Rendering Technique.
• Improved rendering when us
ing the Cross Section Slider wh
ile Edge Smoothing on Idle 
was turned on.
• Fixed a problem that caused reflections to be incorrect i
n the Physically Based Render-
ing Technique if a Watermark was turned on.
• Fixed a crash that could occur using images of certain si
zes as Ambient Occlusion, 
Metal, or Roughness maps.
• Fixed a performance issue involving Ray Casted Shadows th
at occurred while the cam-
era was moving.
• Fixed an issue that caused shadows to be incorrect if onl
y terrain objects were present 
in the plan.
• Fixed an issue in which Ray
Casted Shadows did not work c
orrectly when using the 
Cross Section Slider. 
• Ray Casted Shadows now work
when using the Standard Rende
ring Technique in an 
Cross Section/Elevation view.
• Fixed an issue that could cause the Backdrop color used i
n Vector Views to appear 
slightly washed out.
• Fixed an issue in which Live Views sent to layout using t
he Vector View Rendering Tech-
nique had line weights that were too thick when printed.

3.20 Ray Tracing
• Low roughness materials will now generate perfect reflect
ions in ray trace views.
• Fixed an issue that could cause artifacts to appear aroun
d lights in ray trace views.
• Fixed an issue that caused ray traces of orthographic vie
ws to be incorrect

 

So update patches should shortly be forthcoming.

 

DJP

Share this post


Link to post
Share on other sites

Installed the update.  No changes.

 

I was advised to turn off ambient occlusion - I did so.  No change.  My renderings are still the same as they were in the attached photos.  

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now