UserMjaanes

How can I add 2D SYMBOLS

Recommended Posts

Pleeeease help...

I need to create a 2D plan layout with local national (Norwegian) electrical symbols.

I have all symbols as JPG or GIF and need to get them imported into HomeDesigner Pro 2018, preferably as symbols. I have attached one of the simplest symbols below.

I have around 50 of these (and some are complex), so I can not create them all from scratch, but need to get them imported somehow.

I only need them visible in the 2D layout plan (do not need them in the 3D camera view).
 

I have tried to get them imported via the "IMPORT 3D SYMBOL" function, but I only get an error message saying "No 3D data" (which of course makes sense since these are 2D files).
I have even tried to convert to DWG and DXF, but get the same error message (which I could probably have predicted since there is still no 3D data).

I tried to import them as pictures, but that looks crappy, because they are not transparent, so the whole big encompassing rectangle will cover my other items in the plan, (e.g furniture) since the symbols have to be in front (placing them back makes them invisible)

Any good expert advice?

Thanks

Rgds

Christian

 

 

Stikk1.gif

Share this post


Link to post
Share on other sites
25 minutes ago, UserMjaanes said:

I tried to import them as pictures, but that looks crappy, because they are not transparent, so the whole big encompassing rectangle will cover my other items in the plan, (e.g furniture) since the symbols have to be in front (placing them back makes them invisible)

 

I don't believe Home Designer has the ability to do what you want.

 

The electrical symbols are CAD Blocks, not images.

 

You might try using a file type that lets you have a transparent background, like png.

 

You might also contact support. 

 

Also, electrical plans, normally, do not show furniture, at least here in the US.

Share this post


Link to post
Share on other sites

You can import your images in either .jpg, .jpeg or .bmp image formats into Home Designer. Not as "symbols" as Eric said. They should be resizable once imported. I suggest you place them in a single folder on your Library Browser for easier access and use. Let us know how that works for you please.

 

DJP

Share this post


Link to post
Share on other sites

Thanks for the quick response.

 

One small remaining challenge for the experts......

 

Taking your advice, I ran the symbols via Photoshop to make the background transparent.

I then imported *.PNG an resized.

 

This solves the placement and transparency issue.

 

HOWEVER, I can not turn off the display of these new images.

In TOOLS-DISPLAY_OPTIONS, there is a line called "Images", but this has no effect (regardless of whether the images are copy-pasted or FILE_IMPORTED).

If I can not turn on-and-off, this method will unfortunately not work as I would have to maintain several diagrams (several versions of the house).

 

Any good advice on either.............

1) How to quickly (and temporarily) remove all images (sockets, switches, etc that are now images)   or

 2) Any other solution (is it e.g. possible to somehow make my flat symbol into e.g. a 1 millimeter thick 3D version and then import as 3D symbol) ?

 

Thanks

Rgds

Christian

 

 

capture.jpg

Display_Options.jpg

Share this post


Link to post
Share on other sites

Open one of the images and see which layer it's on.

Share this post


Link to post
Share on other sites

I open one of the two symbols above (by pressing Ctrl-E) and see the following.

I do not see any notion of a layer.

Are we using the same version (I am using Pro 2018)?

Best regards

Christian

capture.jpg

Share this post


Link to post
Share on other sites

It does not show there in the Home Designer products.

 

look in the status bar when an object is selected.

 

ht1.thumb.jpg.cdac22b94bee56471f8103cf2c44bbe6.jpg

Share this post


Link to post
Share on other sites

Fantastic! 
:-)

It says "Object layer CAD, Default"

So, now I can turn off the display of CAD objects and my sockets/switches/etc will also disappear.
Thanks so much.

Rgds

Christian

 

capture3.JPG

Share this post


Link to post
Share on other sites

The tricky part is making sure that all objects on the "CAD Default" layer are what you want to be turned on and off because unlike in Chief Architect Premier you cannot create objects on custom layers or move objects to other existing layers. It is just one of the many reasons Home Designer Pro costs what it costs and Premier costs what it costs.

 

DJP

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now