Sign in to follow this  
SAILOR139

Importing SketchUp models missing or adding extraneous surfaces.

Recommended Posts

I am importing a truss I created in SketchUp to CA.  It comes in with extraneous surfaces.  I have redone the SketchUp truss several times; same conclusion with different extraneous surfaces.  When highlighting the file to import the thumbnail photo of the truss is perfect, but after inserting into CA extra or missing surfaces appear.

 

Has anyone had this problem and aware of a fix.

 

Frustrated

post-4502-0-33347100-1449274150_thumb.jpg

Share this post


Link to post
Share on other sites

As frustrating is this is (understandable) in my experience, what happens in Sketch Up can only be repaired in Sketch Up. Home Designer has no effect on Sketch Up files so if they are messed up in Home Designer, they need to be fixed or redone in Sketch Up. Something you did or failed to do caused the unwanted result.

 

DJP

Share this post


Link to post
Share on other sites

Thanks David.  I have redone this file several times with different results. As stated above the file is perfect.  In various print options it portrays correctly; ie .jpeg and other formats.  It becomes corrupted when it is imported into CA.  I have assume this since it appears perfectly in all other formats.  This is a simple 2D drawing stretched to 1.75" thickness.  Not much can go wrong there.

 

If you are correct then SketchUp is useless for anything but a moulding profile; and, you certainly may be correct.

 

Keep up the replies, I always appreciate your comments.

 

I will try a different approach and see if it will work.

Share this post


Link to post
Share on other sites

David,

 

I recreated the file in polylines all in 0.0000 "z" axis.  Similar problem when imported into CA.  I have contacted tech support for their opinion.  Also, I imported truss from 3D Warehouse with same results.

Share this post


Link to post
Share on other sites

Problem Solved

 

I created the truss three different ways: 1) AutoCad 2D line drawing which was imported into Sketchup, expanded to a 3D SketchUp model and saved; 2) AutoCad 2D polyline drawing which was imported and also expanded to a SketchUp 3D model; 3) created the 3D model in SketchUp and saved.  All three models were imported into CA with same distorted surface (faces) results but with somewhat varying distortions.

 

After many of hours of frustration I stumbled on .3ds format which is a native 3D model file used by AutoCad Studio for rendering.  This is one of several 3D model files which SketchUp can export to.  I exported all three above SketchUp files using .3ds.  All three imported perfectly in CA.  See attachment

 

Apparently, CA does not handle the SketchUp format, .skp, as well as it does .3ds; or, the SketchUp model is not as robust as the .3ds file.

 

If anyone creates a SketchUp model for CA I suggest that you export the SketchUp model using .3ds and not SketchUp native format .skp.

 

I hope this is of some value to others.  I understand all of the above may have already been repeated and I just missed it.

post-4502-0-84851900-1449515763_thumb.jpg

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks for the tip, I got lucky on my SketchUp import, but will now do as a.3ds as you suggest,  Thanks for saving me future problems!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this