Room selection suddenly not working correctly


Go to solution Solved by DavidJPotter,

Recommended Posts

Fortunately, I started my day by saving under a new name. I made only s few changes, and suddenly I can't properly select rooms on the second floor.

There's one large bedroom that can't be selected at all, and all other rooms are selected together plus a border outside the exterior walls of the house.

Image attached.



I opened my version from yesterday and found that the problem started there.

That's several hours or work difference from the previous day, which id OK.


I know that I have a pretty old software version (2011).

My upgrade options expired long ago.

Would it be worthwhile to just buy a new version?


Link to comment
Share on other sites

  • Solution

Look for, find and correct either a wall that is programmed to be "No Room Define" in its dialog box or a wall connection that is not properly connected to solve this situation. You can try the "Fix Wall Connections" command found under the "build - wall+ dropdown menu.



Link to comment
Share on other sites

I was finally able to access the 2nd floor bedroom properties in the 3D view and found that the floor had dropped to the first floor level.

Once I got that fixed, things started working better.

I still had access other rooms in the 3D view to fix ceiling heights to default.

When I made each change, I got warnings about negative ceiling heights and a room would be selected in 2D, but I couldn't do anything other than click away the messages.

When the last error message was gone, so was the selection. I was back to being unable to select the faulty room.

Fortunately, I could get at it in the 3D view.


Now I'm on to new problems.

Thanks much for your suggestion,

I'll mark this as solved.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now