Sign in to follow this  
larana

database disk image is malformed

Recommended Posts

When I try to add library catalogs, I get:

Error executing query: database disk image is malformed No result has been generated

 

I'm staying away from any bonus catalogs for 2017. Everything I've tried is for my 2016 according to the website so I know I'm downloading stuff that should be compatible with my version.

 

I've tried doing a repair install, as well as uninstall and reinstall, but the warning keeps showing up.

How do I fix this?

Share this post


Link to post
Share on other sites

Talk to tech support. 

 

Try making a copy of your library files in another folder.

 

Delete the old ones.

 

Do a repair install.

 

Now try adding new catalogs.

Share this post


Link to post
Share on other sites

Mac may be different. Your computer may be different.

 

post-171-0-13252100-1462984981_thumb.jpg

Share this post


Link to post
Share on other sites

Thank you!

 

I cleared out all of my Core, Manufacturer and Bonus catalog stuff from ProgramData, as well as my User Catalog in the program's Data folder (which was in Documents on my machine) and started over from scratch.

 

Reinstalled the core catalog, redownloaded the bonus and manufacturer ones I got before, reimported the couple of SKP symbols I still had on my Desktop and added them to my User Catalog and no sign of the error again!

I suppose it's likely that it was only one of those files that was actually corrupt and I probably didn't need to wipe EVERYTHING out, so the tech probably will get back to me with less steps, but I'm one happy clam now!

  • Upvote 2

Share this post


Link to post
Share on other sites

Thank you "larana"!  I was about to pull my hair out.  Your post fixed my problem.  (at least for now)  I sure would hate to have to dump it all again later.  I was trying to download the whole catalog and then it would not let me pull up the library at all. :rolleyes:

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this