How to select only terrain to move it?


tbrummel
 Share

Recommended Posts

I've got existing structures and now I'm trying to add terrain (Pro 2021).  I've created a terrain perimeter and many contours w/ elevations.  The terrain looks good in 3D - but the house is in the wrong spot on the terrain.  So, I'm trying to select the terrain and move it.  

 

I've tried many things to no avail.  Tried to select and move the terrain perimeter - but that does not move the enclosed contour lines with it (not sure why you'd want to move a perimeter without its contents but...).  I've also tried locking every layer except terrain in Tools | Display Options.  Oddly, once I do, I can't select terrain.  I noticed that I have to unlock "CAD, Default" in order to be able to select Terrain objects.  This seems like a bug - sure, the terrain contours may be lines underneath the surface, but they are marked as terrain contours so I'd expect that to override their base class.  Unlocking CAD, Default ends up moving more than just the terrain.  So, I'm stuck on what seems like a basic problem.

 

How do I select JUST the terrain (perimeter, contours, lines) so that I can reposition it (the house) on an existing plan?  I've read posts on creating a terrain and selecting all, etc... but that is in a file that does not contain a house.  I've got both a house and terrain and I want to move the terrain and not touch anything else (as I've read in other posts that this is the correct way to "move the house" -- you don't move the house, you move the terrain).


Thanks for any help.

 

Link to comment
Share on other sites

*** I see you said Pro 2021 ***

 

Answers often depend on which title (Suite, Pro etc) and version (2018, 2019 etc) you are using.

 

You can help everyone by adding that info to your signature (see below for how to turn them on) by clicking on your user name at the top right of the page, click Account Settings, then Signature on the left.

 

Doing so makes it always available, and keeps others from having to hunt for it.

 

And, turn on signature display too.

 

SIG.thumb.jpg.af17109346e9446432098056e258623d.jpg

 

----

 

Resources for self help:

 

The built in Help System (always a good place to start)

 

 

 

 
Home Designer - Getting Started - Setting Preferences and Defaults
 
Link to comment
Share on other sites

Thanks for the reply and video.  Sadly, this does not work in my file.  Probably a bug then related to the complexity of the file or terrain.

Here's a link to a video I created of doing the same thing but with the real file.  Note that after I "select" by drawing a bounding box, nothing is selected.

If I unlock CAD, General, then my selection works on the terrain (and other CAD items).  If you think I might be missing something, please let me know. 

Otherwise, I hope the dev team peeks at these threads now and then and, hopefully, this will get fixed.

 

https://1drv.ms/v/s!Au7dyEQFHVz1iL41ZUIGEsf180VwYA?e=Aw7EkB

 

 

Link to comment
Share on other sites

I'd be thrilled to find it's me.  I did the "back up entire plan" (which is missing a couple non-essential graphics files) and it's over the attachment size allowed.

So, here's a link to it.    Ignore the house issues - It's a plan from the 2012 version and some things just don't look the same in 2021. I'll look into that later as it's not important for terrain.  Thanks.

 

https://1drv.ms/u/s!Au7dyEQFHVz1iL42UALU5FOBpyLWpA?e=gASYz2

 

 

 

Link to comment
Share on other sites

2 minutes ago, tbrummel said:

I did the "back up entire plan"

 

That's not needed and just creates a large file.

 

Just the plan file is all that's needed. Make a copy and delete all the extras. Zip and upload.

 

I'm on a slow internet connection and have a couple of videos uploading now which really slows things down.

Link to comment
Share on other sites

I created the terrain in a separate .plan file.  The contour lines were imported via a .gpx file using the HomeDesigner import GPS data function and they were all imported as terrain contours.  In fact, if you double click one of the things you were selecting in the video, you should see that I do have a terrain perimeter and those are all terrain contour lines.

 

Having said that, I noticed you said "on the CAD layer". That's leading me to believe that the object being a terrain perimeter is not sufficient -- it is supposed to be on a terrain "layer" or something?  I'm not sure why that would happen automatically via the import wizard.  Is there a way for me to "move" all this stuff to the correct "terrain layers" to solve this oddity?

 

I really appreciate your help.

 

Link to comment
Share on other sites

11 minutes ago, tbrummel said:

Is there a way for me to "move" all this stuff to the correct "terrain layers" to solve this oddity?

 

Not that I know of, but I've never used the import GPS function.

 

Home Designer in general lacks the ability to assign layers -- you take what the program gives.

 

Are you able to select and move things?

Link to comment
Share on other sites

Oh, I can, as I said in the original OP, if I enable the CAD layer (like you did).  That works but it is moving other CAD layer stuff as well.  Admittedly, in this plan, they are not important so I can live with that.  I'd sure like to know how to properly get things into the terrain layers though.  I'll search the internet some more.  Thanks for your help.

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share