Sign in to follow this  
BugAnnoyer

Create Plant Image doesn't pay attention to PNG transparency

Recommended Posts

This is related to the other post I put today "Object Not Compatible". I noticed that I could browse the .zip in the Reference Files folder, and it contained the .PNG image of the Camellia bush I was trying to use in Plant Chooser. So resourceful me, I figured, I'll just save this and then use it in Create Plant Image to create it manually. However, Create Plant Image doesn't seem to pay attention to the Transparency information in the saved .PNG. Well, that's not entirely true. When you use the defaults where the .PNG has the transparency saved as a particular color in the palette, then it doesn't pay attention and you see it as a solid (in this case) black. If you use the option to save the transparency as the Alpha Channel, then transparency works in Create Plant Image, but then the image itself shows as a sort of ghost, and not solid. Any others having luck with Create Plant Image where you are using your own images?

Share this post


Link to post
Share on other sites

I found what I was doing wrong, have a workaround to my problem (see previous post "Object Not Compatible") and figured out a couple of things about Home Designer / Create Plant Image, and also about the image software I was using (Irfanview). First, Create Plant Image wants to use the Alpha Channel option for PNG transparency, and apparently can't use transparency based on a particular color in the PNG palette. Secondly, I had been opening the files in the Referenced Files .zips using Irfanview (so I could view before saving), and then saving from there using Save As. Apparently, Irfanview has some kind of limitation or bug when handling Alpha Channel transparencies, and that's why I was getting a "ghost" Camellia when doing that. When I simply copied from the .zip file to a temporary location, and then used that file to do Create Plant Image, everything worked as expected.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this