malconium

How do I get text to stay the same when I reverse a plan?

Recommended Posts

I occasionally need to reverse a plan when I am doing a design. I find that when I do so any text that has been rotated 90 degrees so that the bottom of the text is at the right side of the drawing gets mirrored so that the bottom of the text is on the left side. I want the text to stay right reading from the right side. Is there a way to do that with the flip so that I do not have to go in and manually rotate text back to the way I want it?

 

Share this post


Link to post
Share on other sites

there is a setting under Edit >Default>Text>Text Styles>Room Label style> Edit>  uncheck Rotate with plan

 

you may need to uncheck it for Room Label box style too

 

you can do it with out options too such as cabinet labels to as needed

Share this post


Link to post
Share on other sites

I tried what you suggested and got results that were not what I was looking for and in fact were not good ones. The rotated text still mirrors as before when I use the Tools - Reverse Plan command from the menu. What is worse when I use the Tools - Rotate Plan to 90 degrees the room text ends up jumbled on top of each other. The text is still un rotated but the room name, dimensions and area are not right on top of each other.

Share this post


Link to post
Share on other sites

mirrors?  some pics would really help , I am guessing at you descriptions

 

did you also as I said above ..........."you may need to uncheck it for Room Label box style too"

 

the text will jumble up if it's containing "box" (Border) is too small , just make it bigger , turn on borders if needed so you can see them temporarily.

 

M.

Share this post


Link to post
Share on other sites

I have attached 4 JPG snapshots of what I see. The snapshots are the following:

 

test_before.jpg <-- condition before doing anything.

 

test_mirror.jpg  <-- this shows how the vertically oriented text mirrors about the y-axis and is therefore not readable from the right side as before. This behavior is not impacted by the room label text settings you suggested.

 

test_rotate.jpg <-- this is what the text looks like after plan rotate without changing the room label text settings. The rotate with plan boxes are checked.

 

test_rotate_not_text.jpg <-- this shows what happens to the text when I uncheck the two room label related boxes. This shows how the text gets jumbled up.

post-1084-0-01022600-1420932641_thumb.jpg

post-1084-0-02431400-1420932642_thumb.jpg

post-1084-0-00095100-1420932643_thumb.jpg

post-1084-0-99952600-1420932643_thumb.jpg

Share this post


Link to post
Share on other sites

the jumble up text is due to the bounding box being too small in its new orientation , if you change it in the Default settings it should work ok I think , that fixed itself for me when I tried after setting the Room Label Style too.

 

did you try rotating the plan 180 instead of reversing it  (what I think you did)   to cure the "mirroring issue"

 

M.

Share this post


Link to post
Share on other sites

the jumble up text is due to the bounding box being too small in its new orientation , if you change it in the Default settings it should work ok I think , that fixed itself for me when I tried after setting the Room Label Style too.

 

did you try rotating the plan 180 instead of reversing it  (what I think you did)   to cure the "mirroring issue"

 

M.

Where do I go to change the default bounding box for room labels? Also doesn't it seem wrong that when you select not to rotate the text with the plan that the text should change in any way?

 

Rotating 180 degrees is not the same as mirroring a design - so no I did not try that instead of mirroring.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now